Blogumus, la versione funzionante anche su Internet Explorer


image Claudio mi ha segnalato che il widget pubblicato stamattina ha problemi con Internet Explorer 7. In effetti le etichette non sono cliccabili con questo browser. Appena arrivato a casa da lavoro (ovviamente dopo aver sbaciucchiato mia moglie) mi sono subito messo all'opera per sistemare il codice proposto da Blogger Buster ed ecco qui il risultato: il widget Blogumus funzionante anche con Internet Explorer.

Questa versione dovrebbe anche sistemare il problema che hanno avuto alcuni di voi a visualizzarlo nel proprio blog. Se ci fosse più sintonia tra i vari browser in giro per la rete, la vita di un programmatore sarebbe più semplice.

Eliminiamo il vecchio widget

Se non avete aggiunto l'elemento di cui ho parlato nel precedente post, potete saltare questo paragrafo, altrimenti da Layout->Elementi pagina, eliminate il vecchio widget che avete aggiunto. Lo riconoscerete dall'etichetta che avete scelto:

image

Vi apparirà come un normale elemento di tipo "Etichette": cliccate su rimuovi e andate in Layout->Modifica HTML per aggiungere la nuova versione.

Inseriamo il nuovo widget

Cercate la seguente riga di codice:

<b:section class='sidebar' id='sidebar' preferred='yes'>

Subito sotto, incollate:

<b:widget id='Label99' locked='false' title='Categorie' type='Label'>
<b:includable id='main'>
  <b:if cond='data:title'>
    <h2><data:title/></h2>
  </b:if>
  <div class='widget-content'>
&lt;embed type="application/x-shockwave-flash" src="http://halotemplates.s3.amazonaws.com/wp-cumulus-example/tagcloud.swf" id="tagcloud" name="tagcloud" bgcolor="#ffffff" quality="high" flashvars="tcolor=0x000000&amp;mode=tags&amp;distr=true&amp;tspeed=100&amp;tagcloud=&lt;tags&gt;
<b:loop values='data:labels' var='label'>
<a expr:dir='data:blog.languageDirection' expr:href='data:label.url' style='12'><data:label.name/></a>
</b:loop>
&lt;/tags&gt;" width="250" height="200" allowScriptAccess="always"&lt;/embed&gt;

</div>

  <b:include name='quickedit'/>
</b:includable>
</b:widget>

Personalizzando le parti in verde così:

  • Categorie è il nome dell'oggetto
  • 250 e 200 sono rispettivamente larghezza e altezza dell'oggetto, modificatele per adattarle al vostro template
  • ffffff e 000000 sono rispettivamente il colore di sfondo e quello del testo delle etichette, secondo la codifica RGB
  • 12 è la dimensione del carattere

Una volta fatto, potete salvare il template. In Layout->Elementi pagina, troverete un nuovo elemento che potete posizionare dove più vi piace.

Condividi su Facebook, Twitter o Google Buzz:
Condividi su Facebook Condividi su Twitter Pubblica su Google Buzz

Per ricevere direttamente in posta i nuovi articoli, inserisci il tuo indirizzo email:
oppure puoi iscriverti al feed per tenerti sempre aggiornato sui nuovi contenuti del blog!
Per maggiori informazioni sui feed, clicca qui!

70 commenti:

Claudio Pomhey ha detto...

mitico!!! ti metto come primo link nella mia lista dei blog migliori! (non sarà quella di dmoz ma è il massimo con cui posso premiarti!).

è molto carino, per ora lo lascio voglio vedere se la gente perdendo tempo a giocarci si ipnotizza e mi rimane sul sito ore a guardarlo...hihi

the Tramp ha detto...

Niente, Ten purtroppo anche così si vede un rettangolo bianco, sarà destino?

Antonino ha detto...

OTTIMO!!!

Anonimo ha detto...

ciao senti come posso aggiungere nel mio blog degli elementi alla fine del blog, diciamo una barra orizzontale nel basso del blog, fammi sapere complimenti per le guide che fai

Profeta ha detto...

ok, ma noto che non escono tutte le categorie (una ne rimane fuori)!

Tenebrae ha detto...

@tramp: strano, anche perchè io l'ho provato proprio sul minima.. prova a rimpicciolire le dimensioni del widget, forse viene tagliato e sembra vuoto?

@anonimo: è una cosa che mi è stata chiesta e presto pubblicherò un post che spiega come fare

@profeta: dovrebbe restare fuori solo quella corrente

Anonimo ha detto...

ok grazie mille

Giuliana ha detto...

installato!!!

Den ha detto...

Inserito! Ho solo un problema (penso sia lo stesso di Profeta). Non appargono mai tutte le categorie (ne "scompare" sempre una a caso) anche se ci sono tanti post con quella etichetta. Se clicco su una categoria quella rimane nell'elenco, ma non ne visualizza sempre una. Spero che tu possa aiutarmi :(

Manu ha detto...

Niente Ten.. rimane la finestrella bianca.. questo è un complotto cosmico...

Tenebrae ha detto...

@claudio: sempre soddisfazioni sono ;)

@den: è una in particolare che rimane fuori? sempre quella? fammi un esempio... tipo cliccando su questa scompare quest'altra... io nelle mie prove con questa versione non ho avuto questi problemi

Tenebrae ha detto...

@manu: hai provato in un template diverso, magari un blog di prova?

DR ha detto...

Ho apportato la modifica e funziona! Grazie...

Den ha detto...

L'etichetta mancante cambia sempre. Soprattutto scompargono "i cesaroni 3" e "anticipazioni" (rispettivamente queste categorie comprendono 4 e 5 post). Se clicchi sopra ad una etichetta non cambia nulla: ne scompare sempre una a caso. Mi succede la stessa cosa anche sul mio blog di prova. Fammi sapere...

zia lella ha detto...

ciao, ho provato a inserire la tua stringa, ma non me la accetta. Perchè, perchè, perchè...(è chiara la disperazione?) illuminami, custudiscimi, reggi ecc. ecc.) ciao e a risentirci presto.
ps complimenti è un blog bellissimo!!!

Jackie ha detto...

Ma come mai nonostante abbia installato l'elemento nuovo (e si vede nel Layout!)nel blog non compare nulla,nemmeno un rettangolo bianco?

profeta ha detto...

ok,gentilissimo come sempre

Decoratrice Italiana ha detto...

Funziona perfettamente...sei sempre affidabile e preciso! Posso chiederti se sai spiegarmi come mai non riesco a cambiare la mia foto del profilo su blogger? Ho eliminato la gif animata dal server ma da qualche parte compare ancora! Come posso fare...sulla pagina apposita:modifica foto del profilo... mi è impossibile caricare un nuovo file.jpg...grazie anticipatamente...e adesso vedrò se compare il mio avatar qui!

chiaiamichio@yahoo.it ha detto...

Io ho provato, ma non riesco... che dramma.... mi viene fuori lo spazio con scritto categorie, ma le categorie compaiono alla fine e in ordine normale..... ahhhhh!!!!!
Kia

Lulaj2190 ha detto...

hey ciao, io ho provato a seguire la tua guida ma non riesco a trovare la stringa B:SECTION ECC.. pensi che possa dipendere dal template che ho installato?

deadiana ha detto...

sei mitico ti ho trovato grazie alle pazzielle di Sisifo io sono www.paneola.blogspot.com ciao e a presto

sbondo ha detto...

Ciao, sono riuscito a farla funzionare su un template con una colonna nella sidebar, ma sul langit proprio nn ci riesco...
Nel senso che la installo, sia a destra che a sinistra ma con ie mi dice "impossibile aprire bla bla bla, operazione terminata"...

Posso rinunciarci?

Ciao!

sbondo ha detto...

Ovviamente l'errore me lo da quando con ie clicco su una label...Apre la pagina ma poi da qurl messaggio

Mi sembrava giusto precisarlo

Ciao

Tenebrae ha detto...

@lulaj: ho visto nel tuo blog che hai risolto il problema :)

Schiphol ha detto...

bella fratello ;-)

Alessandro Pistillo ha detto...

ciao, ho provato in entrambi i modi, ma mi da sempre l'errore "È stato trovato più di un widget con ID: HTML2. Gli ID dei widget devono essere esclusivi."
Premetto che ho un blog con tre colonne (lo puoi vedere quì http://pilloleditecnologia.blogspot.com/). Mi puoi spegare come fare? é troppo carino sto Tag cloud e ci terrei ad averlo nel mio blog. Grazie

Tenebrae ha detto...

@alessandro: vedo che hai risolto ;)

Claudio Pomhey ha detto...

Senti Tenebrae mi serve un supporto, riesci a sostituire sul codice la parola "embed" con la parola "object" ?
Io ci ho provato ma non sono abile con la programmazione, cosi accontentiamo il w3c

Tenebrae ha detto...

caspita claudio, non è che mi stai diventando troppo accademico? ;)

il w3c non lo accontenteremmo comunque, visto che già blogspot non lo accontenta

e darebbe problemi con internet explorer

Claudio Pomhey ha detto...

hehe...è vero...vabbene boss!!

mary47 ha detto...

Ciao e grazie per le dritte. Ho eseguito quanto descritto, sul Blog però non appaiono come da descrizione. Cosa posso fare. Ti ringrazio anticipatamente. Riciao

sucardrom ha detto...

ho qualche problema sul colore di sfondo? non sono riuscito a modificare il bianco. è possibile?

Tenebrae ha detto...

@sucardrom: purtroppo non posso visualizzare il tuo blog (il tuo profilo è privato) quindi non posso darci un'occhiata... ma non dovrebbero esserci problemi, controlla attentamente il codice!

Alessandro Pistillo ha detto...

Si ho risolto, grazie lo stesso.

mary47 ha detto...

A tutt'oggi non ho ancora risolto, quando potrai fai una visita al mio blog evedi l'inghippo (chedo troppo? Scuuusaaamiii.
Ciao e buona giornata!

Politicamente Scorretto ha detto...

Strano, l'ho inserito giusto ma da me non va...è forse dovuto al fatto che ho la sidebar su tutti e 2 i lati del blog?

vicio ha detto...

sul minima funge sul mio spunta un rettangolone bianco

Tenebrae ha detto...

@vicio: è un problema che qualcuno continua a riscontrare, posso solo pensare che sia un problema di template, probabilmente qualcosa va in conflitto

vicio ha detto...

mizza svelti qui sui commenti pure la sera tardi

Tenebrae ha detto...

puro caso credimi, era di passaggio :)

tytania ha detto...

e se uno volesse metterlo in un template che non è su blogspot? sai come si fa?
grazie (e grazie per questo blog che è utilissimo!!!

Tenebrae ha detto...

@tytania: bella domanda.. potrei studiare un modo di farlo anche per splinder, se ti interessa quello!

tytania ha detto...

mi interessa se si può fare il label cloud come quello che avevo su blogspot qui, era troppo una figata!

Tenebrae ha detto...

@tytania: ne parlerò presto!

tytania ha detto...

grazie ;)

mackos-gnu ha detto...

grazie per il bel passaparola.
buo carnevale.

Gig ha detto...

Ciao! Il widget é bellissimo, ma da me non riesce ad installarsi! Non so per quale motivo, mi compare solo tutta la striscia infinita di tag nella sidebar di destra, senza che di Blugumus compaia alcunchè!

Se puoi provare a fare qualcosa, il mio link é http://calledelvento.blogspot.com! Se ce la fai alemno un linkaggio é garantito!

Grazia, e scusa per il disturbo!

Gig:)

Simone e Anita ha detto...

Ciao bellissimo blogumus però dopo un mese di funzionamento non va più come può essere
Simone

sonia a. ha detto...

grazieeeeeeeeeee!!!!!!! utilissimo questo tutorials ;)mi funziona benissimo :)

Zer0nestO ha detto...

funziona bene ma ho lo stesso probblema riscontrato in altri commenti, mi scompare sempre una categoria, ogni volta diversa. come posso fare?
ho imparato tantissimo dal tuo blog e te ne sono grato, 6 mitico.
ciao Zer0nestO

ELENA ha detto...
Questo commento è stato eliminato dall'autore.
ELENA ha detto...

ciao,scusa ma senza accorgermi ho cancellato dei miei post che avevo lasciato.

comunque volevo dire che anche io ho riscontrato il problema che hanno esposto altri, ovvero, vengono pubblicate tutte le etichette meno una (che cambia di volta in volta)

lukiz ha detto...

ciao. anche io ho stesso problema di simone. non funziona più, di colpo. in apparenza senza aver fatto nulla.
grazie e bel blog. [si imparanao molte cose. e ben spiegate, soprattutto]

Tenebrae ha detto...

ho visto in molti blog che lo usano che il componente va benissimo, è molto strano che vi sia scomparso all'improvviso, posso solo consigliare di rimetterlo, magari è stato qualche aggiornamento di blogger a farlo saltare

il fatto che scompaia una categoria possiamo imputarlo solo a un errore del widget, purtroppo può correggerlo solo l'autore :( se ci saranno aggiornamenti in merito, comunque, lo farò presente

arianna ha detto...

ciao :) bello il tuo blog!! complimenti! ho provato ma non ci sono riuscita....o meglio sul blog di prova si e su quello vero no..mi compare una finestra bianca!! :)) ho anche salvato il blog ma poi quando l'ho esportato non mi ha dato le etichette come le avevo messe!! x(
dimmi in caso non rieco come posso far rientrare l'etichette come le avevo messe all'inizio?

grazie :) by da fruttella

@nn@ ha detto...

ciao Ten, a me appare una finestra vuota oppure, se cliccando sugli strumenti modifico una qualsiasi impostazione (tipo "tutte le etichette"/"etichette selezionate"), nella finestra SI VEDE il codice html, inframmezzato dalle etichette b-(


ma sai qual è la cosa più strana? che nel blog di prova, sul quale ho caricato lo STESSO IDENTICO modello del blog ufficiale, il widget funziona PERFETTAMENTE ~x(

luna m ha detto...

ciao! complimenti per il blog: hai il pregio di essere chiaro e competente allo stesso tempo.
ho installato il widget, appare correttamente ma cliccando sui tag non succede niente.
sai dirmi perché?
http://www.lunamargherita.com

grazie!

Mela ha detto...

Ciao a tutti, anche io avevo il problema della finestra immobile (insomma, il widget non pareva funzionare) e sembra abbia trovato uno soluzione, ve la propongo, caso mai servisse a qualcuno.
Innanzi tutto devo precisare che a me non si visualizzava sul mio blog, ma vedevo funzionare normalmente Blogumus su altri blog. Meglio verificare se ciò avviene, perchè nel mio caso mi ha fatto escludere l'ipotesi di malfunzionamenti del flash player.

Ora, se siete sicuri di aver fatto tutto per bene, e che tutto funziona come deve, provate a:
- da layout -> elementi pagina entrate nel menù del widget (etichette, tag, o come l'avete chiamato...)
- anzichè mostrare tutte le etichette, scegliete di selezionarne solo alcune (es. il mio blog è agli inizi ed ho solo ca. 15 etichette, gliene ho selezionate 13...)

Fatto ciò a me ora funziona, se torno a tutte le etichette... nisba!

La rottura è che ogni volta che aggiungete un'etichetta, dovete aggiungerla anche lì ma tutto sommato sembra più veloce che agire da html.

Se vi va provate!

Ciao
Melania

PS: stranamente, invece, non riesco a modificare il colore del testo: malgrado l'abbia cambiato da html (e se controllo risulta #FFFFFF), continua a darmelo nero anzichè bianco... Boh! Se qualcuno ha consigli sono bene accetti.

Gio ha detto...

Ciao, ieri appena inserito il widget funzionava a meraviglia, oggi non si vede niente, solo uno spazio bianco, ho riprovato ad inserirlo ex-novo, ma ancora niente ... mah sarà che di domenica va in ferie!
Comunque grazie i buoni consigli e complimenti per il tuo blog veramente utilissimo

Gio ha detto...

Rettifico, funziona su safari ma non su firefox, explorer non lo so

jessica lombardia ha detto...
Questo commento è stato eliminato dall'autore.
jessica lombardia ha detto...

ti informo che questo bellissimo gadget non funziona piu, io è da l'anno scorso che lho inserito sui miei due siti ma da circa 5 giorni è sparito e appare questa scritta (Blogumulus by Roy Tanck and Amanda Fazani) per favore puoi riaggiornare i codici mi piaceva molto questa sfera cosi originale grazie ciao

Simmy ha detto...

Ciao Orazio!!
Ieri ti chiedevo perchè da due giorni non mi funziona blogumus, mi hai indicato questo post ...In realtà è questo il post che avevo seguito tempo fà e per mesi ha sempre funzionato perfettamente sin dal primo giorno.Ora però son 3 giorni che non va più, ho provato a ripetere ex novo la procedura qui descritta, ma niente...ufff...vabò, grazie lo stesso!!! Era cosi carinooo....
Grazie per la disponibilità!!!
Simona

Mirò ha detto...

Anche a me è successo come a Simmy, da tre giorni non funziona più, provato e riprovato ma niente da fare.In questi giorni ha smesso di funzionare anche il gadget del meteo. Boh!!! Grazie comunque. Ciao

Barbara ha detto...

Ciao Orazio! Tempo fa avevo installato la nuvoletta proprio leggendo questo post. Ha funzionato perfettamente fino a pochi giorni fa, poi è sparita improvvisamente. Ho provato ad installarla di nuovo, ma niente da fare... compare il titolo CATEGORIE e mi fa cambiare il colore dello sfondo, ma oltre a questo non si legge altro... che cosa può essere successo? Grazie mille!
A presto!
Barbara

Splashboom ha detto...

Anche a me funziona solo su opera. Si può rimediare? senza ricorrere al label cloud di blogger, che non mi piace

blog di prova ha detto...

Ciao non funziona puoi rimediare con codici nuovi?? Grazie

Veronica ha detto...

Grazie. Perfetto.

Matteo Barboni ha detto...

Anche a me non funge più, ciao

Giovanni Brodu ha detto...

segnalo un problema, per coloro che hanno usato il designer di modelli questo widget non è applicabile, ecco perchè al 90% di coloro che lo hanno aggiunto ora non li funziona più


Prima di lasciare un commento, leggete qui

Posta un commento